Major Outage: Craft.io Applications (US Data Center)

Incident Report for Craft io

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 22:26 IDT

Update

System Status Update: We're currently experiencing a general outage impacting our US environment due to an issue with Google Cloud. We're actively monitoring the situation.
Posted Jun 12, 2025 - 22:02 IDT

Investigating

We are currently experiencing an unplanned outage affecting Craft.io Applications in US Datacenter. Users may be unable to access or use the service at this time.
Our engineering team has been alerted and is actively investigating the issue with the highest priority. We are working to restore full service as quickly as possible.
We apologize for any inconvenience this causes and will provide an update here within the next minutes.
Posted Jun 12, 2025 - 21:27 IDT
This incident affected: Craft.io Applications (US Data Center) (Core App (US Data Center), Public API (US Data Center), Feedback Portal (US Data Center)).